CMSWordpress

A versión 5.2 de WordPress, denominada « Jaco » xa está dispoñible

As novas funcións desta actualización fan que sexa máis fácil que nunca arranxar o teu sitio se algo vai mal.

Comprobación da saúde do sitio

A partir das características de saúde do sitio introducidas en 5.1, esta versión engade dúas novas páxinas para axudar a depurar problemas de configuración comúns. Tamén engade espazo onde os desenvolvedores poden incluír información de depuración para os xestores do sitio.

Protección de erros de PHP

Esta actualización enfocada ao administrador permitirá que corrixas ou manexes con seguridade os erros fatais sen necesidade de tempo de desenvolvemento. Posúe un mellor manexo da chamada “pantalla branca da morte” e un xeito de entrar no modo de recuperación, que pon en pausa plugins ou temas que causan erros.

Melloras para todos
Actualizacións de accesibilidade
Varios cambios traballan en conxunto para mellorar a conciencia contextual e o fluxo de navegación do teclado para os que usan lectores de pantalla e outras tecnoloxías de asistencia.

Novas iconas do panel de control
Trece novos iconos como Instagram, un conxunto de iconas para BuddyPress e iconas rotados da Terra para a inclusión global. Atópaos no Dashboard e divírtete!

Comprobacións de compatibilidade de plugins
WordPress agora determinará automaticamente se a versión de PHP do seu sitio é compatible cos complementos instalados. Se o complemento require unha versión máis alta de PHP que o seu sitio web, WordPress non lle permitirá activalo, evitando posibles erros de compatibilidade.

Melloras para desenvolvedores
Versión PHP Bump

A versión mínima PHP dispoñible agora é 5.6.20. A partir de WordPress 5.2 *, os temas e os complementos poden aproveitar con seguridade espazos de nomes, funcións anónimas e moito máis.

Actualizacións de privacidade

Un novo modelo de páxina de tema, unha función condicional e dúas clases CSS fan máis doado o deseño e personalización da páxina da política de privacidade.

Novo gancho para o corpo

5.2 introduce un gancho wp_body_open, que permite aos temas soportar o código de inxección no inicio do elemento <body>.

Construír JavaScript

Coa adición de configuracións webpack e Babel no paquete wordpress / scripts, os desenvolvedores non terán que preocuparse de configurar ferramentas de construción complexas para escribir JavaScript moderno.

* Se está executando unha versión antiga de PHP (menos de 5.6.20), actualice o seu PHP antes de instalalo 5.2.

Podes descargar WordPress 5.2. ou visitar o teu Escritorio → Actualizacións e facer clic en Actualizar agora. Os sitios compatibles coas actualizacións automáticas en segundo plano xa están a empezar a actualizarse automaticamente.

victorjqv
the authorvictorjqv
Son médico especialista en Medicina Familiar e Comunitaria. Gústanme os retos, botar unha man e axudar ás persoas no mundo real e virtual. Traduzo aplicacións ao galego, deseño webs, programo aplicacións e colaboro na Comunidade WordPress. Actualmente son coordinador global de traducións e administro a páxina oficial de WordPress en lingua galega.

Deixa unha resposta